this post was submitted on 06 Jul 2024
1529 points (99.4% liked)

Programmer Humor

18961 readers
1074 users here now

Welcome to Programmer Humor!

This is a place where you can post jokes, memes, humor, etc. related to programming!

For sharing awful code theres also Programming Horror.

Rules

founded 1 year ago
MODERATORS
you are viewing a single comment's thread
view the rest of the comments
[–] [email protected] 13 points 1 month ago (3 children)

Hard disagree. It's a lot easier and faster to understand a function that is prefaced with a small line of text explaining what it does rather than trying to figure it out yourself.

It's not about whether you can understand the code or not, it's about efficiency and clarity.

[–] [email protected] 7 points 1 month ago

Yeah, just 15 seconds and jot down a comment. Whenever I’m even hesitant, I just leave a comment. Doesn’t hurt anything and it can always be removed if not needed

Easier to remove later rather than add it after the fact

[–] [email protected] -1 points 1 month ago (1 children)

Hard disagree - that's just dumb:

// Calculates tax
function calculateTax() { }
[–] [email protected] 10 points 1 month ago* (last edited 1 month ago) (2 children)

Hard disagree - that's very helpful:

// Calculates Personal Income Tax by formula from section 1.2.3 of tax code. Other taxes like VAT are not calculated.
function calculateTax() { }
[–] [email protected] 5 points 1 month ago

This guy gets it.

[–] [email protected] -4 points 1 month ago (2 children)

If it calculates personal income tax, just call calculatePersonalIncomeTax.

[–] [email protected] 2 points 1 month ago (2 children)

Why not calculatePersonalIncomeTax123 then?

[–] [email protected] 3 points 1 month ago

I'm a new developer. Is that referring to page 123 of the in-house documentation? Version 12.3 of the code? I have no clue.

You'd have to call it something like calculatePersonalIncomeTaxPerTaxCodeSection1_2_3, but I get exhausted just looking at that. There comes a point where the cognitive work of reading crazy long camel case names is more trouble than it's worth.

An explanation of what specification a function was written to implement is a perfectly appropriate comment. Could be improved by a direct link where possible. But it's worth noting what that comment isn't doing - specifying any implementation details. For that, I really can just read the code.

[–] [email protected] 1 points 1 month ago

Yeah, why not?

[–] [email protected] 2 points 1 month ago (1 children)

Is that state, federal, or combined?

[–] [email protected] 0 points 1 month ago
[–] [email protected] -1 points 1 month ago

If done right, the "what it does" is in the method name. If your method is too complicated to summarize in its name, chances are good you should split it up or extract parts of it.