711
submitted 1 month ago by [email protected] to c/[email protected]

geteilt von: https://lemmit.online/post/3018791

This is an automated archive made by the Lemmit Bot.

The original was posted on /r/ProgrammerHumor by /u/polytopelover on 2024-05-26 21:23:20+00:00.

top 50 comments
sorted by: hot top controversial new old
[-] [email protected] 199 points 1 month ago* (last edited 1 month ago)

First one are method name, second one are status name.


def open_file_dialog(self):
       self.dialog_file_open = True
       pass

Yoda level preference war.

[-] [email protected] 99 points 1 month ago

I tend to add is to booleans toreally differentiate between a method name and a status.

def open_file_dialog(self):
    self.dialog_file_is_open = True
    pass

That way, it's easier for my dumb brain to spot which is which at a glance.

[-] [email protected] 112 points 1 month ago

is_dialog_file_open

fite me

[-] [email protected] 58 points 1 month ago

No fiting. IS always goes at the start of names for booleans you are correct

load more comments (3 replies)
[-] [email protected] 18 points 1 month ago

In Elixir, we mark statuses by using a question mark at the end of the variable name. Something like this:

authorized? = user |> get_something() |> ensure_authorized?()

I like this better than the is_ prefix

[-] [email protected] 9 points 1 month ago* (last edited 1 month ago)

does '?' have type definition in elixir or this is generally agreed design pattern?

[-] [email protected] 8 points 1 month ago

If it's like Lisp, then ? is just part of the symbol and doesn't have any special syntatic meaning. In different Lisps it's also convention to end predicate names with a ? or with P (p for predicate)

load more comments (3 replies)
[-] [email protected] 25 points 1 month ago* (last edited 1 month ago)

This is the way.

Command statement = an action

Question statement = a status

load more comments (1 replies)
[-] [email protected] 71 points 1 month ago

There is a reason why little endian is preferred in virtually 100% of cases: sorting. Mentally or lexicographically, having the most important piece of information first will allow the correct item be found the fastest, or allow it to be discounted/ignored the quickest.

[-] [email protected] 26 points 1 month ago* (last edited 1 month ago)

That's actually filtering not sorting.

That being said, it's more valuable (to me) to be able to find all my things for a topic quickly rather than type.

Foo_dialog

Foo_action

Foo_map

Bar_dialog

Bar_action

Bar_map

Is superior IMHO.

load more comments (4 replies)
load more comments (2 replies)
[-] [email protected] 70 points 1 month ago

I'm truly torn with this. The first one seems sensible (action -> target) and easier to read and reason about (especially with long names), while the other one looks more organized, naturally sortable and works great with any autocompletion system.

[-] [email protected] 18 points 1 month ago

Not a programmer, but I'd prefer right naming convention because sorting

[-] [email protected] 13 points 1 month ago

I am a programmer, and i also like the naming scheme on the right

Especially for things like filenames

load more comments (1 replies)
[-] [email protected] 15 points 1 month ago

We need a new framework, one that allows universal lookup, and makes life easier

x = _.dialog.file.open
y = _.open.file.dialog
z = _.file.open.dialog
a = _.file.dialog.open

Once done, the formatter simply changes everything to _.open.file.dialog

Let's get this done JS peeps

\s

load more comments (3 replies)
[-] [email protected] 63 points 1 month ago

Where's file_dialogue_open

[-] [email protected] 37 points 1 month ago

We're all trying our best to ignore the Americans and you bring up m/d/y... why!

[-] [email protected] 27 points 1 month ago* (last edited 1 month ago)

This is the real big-endian way. So your things line-up when you have all of these:

file_dialogue_open
file_dialogue_close
file_dropdown_open
file_rename
directory_remove

If I were designing a natural language, I'd put adjectives after the nouns, so you start with the important things first:

car big red

instead of

big red car

[-] [email protected] 9 points 1 month ago

literally spanish lol

load more comments (6 replies)
[-] [email protected] 11 points 1 month ago

To be fair, it's also missing open_dialog_file, dialog_open_file and most crucially file_open_dialog

[-] [email protected] 48 points 1 month ago* (last edited 1 month ago)

I prefer everything to be how you would read it as text. So create_file_dialog it is. Honorable mention is to have it namespaced in a class or something which I think is best. file_dialog.create or dialog.create_file or even dialog.file.create

load more comments (2 replies)
[-] [email protected] 47 points 1 month ago

I do one, the other senior dev does the other. We fight about it in pull requests.

[-] [email protected] 36 points 1 month ago

Your team needs to have a coding standards meeting where you can describe the pros and cons of each approach. You guys shouldn't be wasting time during PR reviews on the same argument. When that happens to me, it just feels like such a waste of time.

[-] [email protected] 20 points 1 month ago

Preachin to the choir, friend. I'd get worked up about it but I'm paid the same regardless of how upset I get.

load more comments (2 replies)
load more comments (1 replies)
[-] [email protected] 28 points 1 month ago

Can't remember which is which but if it's organized in a top-down way (broad category first) that's just easier to look at and find stuff in the file system. I don't want to have to actually read and mentally process the names of every single file to figure out if it's the one I need. Sure, the "human readable" names are fine and good when you don't have hundreds of them you're trying to look through, but big projects I find are way easier to parse with the category naming.

[-] [email protected] 22 points 1 month ago

US Army logistics catalogs are organized this way. "Cookies, oatmeal" instead of "Oatmeal cookies" because it's a lot easier to find what you need an a giant alphabetical list.

load more comments (1 replies)
load more comments (1 replies)
[-] [email protected] 23 points 1 month ago

Variety is the spice of life.

[-] [email protected] 22 points 1 month ago

Mmmmmmmm... Lexicographical Endianness.

[-] [email protected] 20 points 1 month ago

I used to like the action followed by direct object format, until some time ago when trying to find methods or variables related to a specific object. If the action comes first, scanning for the object without an IDE means first reading unnecessary information about the action. That convinced me to opt for $object-$action in situations where it makes sense.

For example in CSS, I often scan for the element, then the action, so $element-$action makes more sense. BEM kinda follows this. When dealing with the DOM in JS, that makes sense too button.fileDialogOpen(), button.fileDialogSend(), ... makes more sense when searching.

Of course one has to use it sensibly and where necessary. If you are writing a code that focuses more on actions than objects, putting the action first makes sense.

A similar thing is definition order.

def main(args):
  result = do_something(args.input)
  processed = process_result(result)
  transformed = transform_object(processed)
  return transformed.field

def do_something(some_input):
  ...

def process_result(result):
  ...

def transform_object(obj):
  ...

I find this much easier to follow than if main were defined last, because main is obviously the most important method and everything else is used by it. A flattened dependency tree is how these definitions make sense to me or how I would read them as newbie to a codebase.

Anti Commercial-AI license

load more comments (1 replies)
[-] [email protected] 19 points 1 month ago

the people who chose the first one...who hurt you?

[-] [email protected] 26 points 1 month ago
[-] [email protected] 11 points 1 month ago

No one, it just makes sense.

You must be one of those "Throw your mother downstairs, the box of tissues" types.

Yoda sounded normal to you I bet.

[-] [email protected] 10 points 1 month ago

It makes sense until you write 30 methods to manipulate the data layer.

load more comments (1 replies)
load more comments (1 replies)
load more comments (1 replies)
[-] [email protected] 18 points 1 month ago
load more comments (1 replies)
[-] [email protected] 17 points 1 month ago

I worked at a place where all the DB column names were like id_user, id_project. I hated it.

load more comments (2 replies)
[-] [email protected] 15 points 1 month ago

I personally prefer dialogs.FileDialog.open()

[-] [email protected] 15 points 1 month ago

Whatever is more useful goes first.

For example, if this we're a list of UI text strings, finding all of the dialogue options together might be useful.

If, instead, this is a series of variables already around one dialogue, then finding the open or close bits together would be useful.

[-] [email protected] 15 points 1 month ago

Powershell has a lint warning for functions that don't follow Verb-Noun format, and verbs here are a list of approved verbs lol

[-] [email protected] 13 points 1 month ago

I just name my variables a, b, c etc. If I have more than 26 variables in any given function, I name them aa, ab, ac, etc.

load more comments (1 replies)
[-] [email protected] 13 points 1 month ago
[-] [email protected] 30 points 1 month ago* (last edited 1 month ago)

New file

New file (2)

New file (3)

New file (4)

[-] [email protected] 10 points 1 month ago
[-] [email protected] 8 points 1 month ago

sjajvxuwjdofgwu

AjsgGhS77bndugxg

gehshagfahcdvwjdvwjd

AjsgGhS77bndugxg (2)

load more comments (1 replies)
load more comments (1 replies)
[-] [email protected] 12 points 1 month ago* (last edited 1 month ago)

Both:

dialog_error = Dialog_plain.create_modal(error_text)

Variable and class names go from more general to more particular, functions begin with a verb.

Global functions are either "main", or start with one of "debug", "todo", or "shit".

[-] [email protected] 12 points 1 month ago
[-] [email protected] 11 points 1 month ago

First of all, it's spelled dialogue

[-] [email protected] 14 points 1 month ago

Two wars can exist simultaneously.

load more comments (4 replies)
[-] [email protected] 9 points 1 month ago* (last edited 1 month ago)

The object/class/thing would normally be its own class file, the action would be a method/function of said class.

Ie:

fileDialog.open()

fileDialog = Class (Dialog), Subclass (FileDialog)

[-] locuester 8 points 1 month ago

It’s referring to variable names. For example, you have a variable named fileDialog. I would prefer to have that named dialogFile.

[-] [email protected] 8 points 1 month ago

I know the second one is better, but I also know I'm terribly inconsistent with this stuff.

load more comments (1 replies)
load more comments
view more: next ›
this post was submitted on 27 May 2024
711 points (97.8% liked)

Programmer Humor

18396 readers
517 users here now

Welcome to Programmer Humor!

This is a place where you can post jokes, memes, humor, etc. related to programming!

For sharing awful code theres also Programming Horror.

Rules

founded 1 year ago
MODERATORS